1988 Venturi 200 - tech help needed

Chat about VENTURI, Delorean & Kitcars

User avatar
User

PaulC1959

Rank

Club Member

Club Member
Posts

1011

Joined

Sun Oct 15, 2006 8:56 pm

Location

Bedfordshire


Has thanked: 1 time
Been thanked: 3 times

Re: 1988 Venturi 200 - tech help needed

Postby PaulC1959 » Sat Dec 10, 2016 12:32 pm

Tristan

I hope this helps, the relevant page from the owners manual, only a photo though. :up
You do not have the required permissions to view the files attached to this post.
Venturi 260 - Saphir (Blue)
Renault Sport Megane 230 F1 Team R26 - Liquid Yellow
Renault Megane Maxim 1.5 DCi - Extreme Blue (Daily Runner)
Minari RS - Coral Red
User avatar
User

darrenbiggs

Rank

Club Member

Club Member
Posts

1303

Joined

Thu Apr 29, 2004 1:03 pm

Location

Horley - Nr Gatwick


Has thanked: 8 times
Been thanked: 27 times

Re: 1988 Venturi 200 - tech help needed

Postby darrenbiggs » Sat Dec 10, 2016 1:56 pm

On the GTA that light is often sensor related, example being the coolant temp feed to the ECU being out of range. If it's flashing it's often the actual connector as opposed to the sensor that's at fault.

Worth unplugging a few and giving them a squirt of Servisol, wipe clean, dry and re-connect. Some people zip-tie the connectors together to ensure a better contact.

Also another top tip, open the engine bay at night (in the dark with the car running) and look closely along the HT leads. You shouldn't see anything. If you can see blue arcing then the insulation is breaking down so best replace.

Dizzy cap is another potential suspect but you've done that right?
I'm just here for the gasoline.
Previous


  • Advertisement

Who is online

Users browsing this forum: No registered users and 4 guests

Powered by phpBB ® | Renault' and 'Alpine' are trademarks of Renault S.A.S. or its subsidiaries and are used with kind permission of Renault France