speedo electric motor

Renault & Alpine General Discussion

Moderators: eastlmark, BIG_MVS, phildini, Alpineandy, Test Moderator

no avatar
User

claudiu_rem

Rank

Club Member

Club Member
Posts

40

Joined

Fri Dec 08, 2017 1:47 pm


Has thanked: 4 times
Been thanked: 0 time

speedo electric motor

Postby claudiu_rem » Wed Feb 21, 2018 11:08 am

Hi guys. Managed to find to problem for my non working speedo. The electric motor of the speed gauge is gone. Anyone have one for sale or know any method on repairing it? Does it fit from other Renault gauges?
You do not have the required permissions to view the files attached to this post.
User avatar
User

BIG_MVS

Rank

Club Member

Club Member
Posts

5222

Joined

Wed Jun 30, 2004 9:12 am

Location

Sandbach


Has thanked: 37 times
Been thanked: 68 times

Re: speedo electric motor

Postby BIG_MVS » Wed Feb 21, 2018 11:42 am

Ah that would explain it! Looks like someone wanted to keep the miles down on it...

All I have left is in my ebay link below. Clee might have a clock set. Sorry not sure if they are shared with other models but it's a possibility.
1994 A610 - Montana Red
Some GTA/A610 Parts For Sale:
http://www.ebay.co.uk/sch/hertzvanhire/ ... pg=&_from=
User avatar
User

simontaylor

Rank

Club Member

Club Member
Posts

5416

Joined

Thu Apr 15, 2004 12:33 pm

Location

Fleet, Hampshire


Has thanked: 29 times
Been thanked: 44 times

Re: speedo electric motor

Postby simontaylor » Wed Feb 21, 2018 12:04 pm

John C is likely to be along later and maybe able to provide some information, or even some repair hints.
1986 : '86 GTA v6 BW-EFR turbo, with Adaptronic ECU
Firsts at
2007 : Gurston Down & RAOC Champion
2008 : Rushmoor & Eelmoor & ACSMC Hillclimb class Champion
2009 : Longcross & Eelmoor
2010 : Crystal Palace & Eelmoor
2016 : Rushmoor & 5th O/A
User avatar
User

JohnC

Rank

Club Member

Club Member
Posts

2132

Joined

Sun Dec 02, 2007 6:19 pm

Location

Jersey C.I.


Has thanked: 14 times
Been thanked: 72 times

Re: speedo electric motor

Postby JohnC » Wed Feb 21, 2018 2:48 pm

Before you right the motor off ...... unless you have already done so ..... it would be worth detaching the odometer unit from the assembly then check the motor again. The odometers have been known to seize up and as they are driven by the same motor can give the impression that the motor is faulty.
There is a post on this subject in the RAOC Members Area but unfortunately the pictures have been blocked by Photobucket, but I have now found the originals (with some trouble) and will edit the post this afternoon. It can be seen under "GTA speedo faults" dated "Wed Sep 29. 2010".
John
1990 GTA Atmo, 2003 Jaguar X type 2.5SE Auto, 2018 Kia Picanto GT-Line-S 1.25


  • Advertisement

Who is online

Users browsing this forum: No registered users and 9 guests

Powered by phpBB ® | Renault' and 'Alpine' are trademarks of Renault S.A.S. or its subsidiaries and are used with kind permission of Renault France