my gta v6 turbo

A place to showcase your pride and joy

Moderators: eastlmark, BIG_MVS, Test Moderator

no avatar
User

andy001

Rank

Non Member

Posts

974

Joined

Sat Jul 18, 2009 6:09 pm


Has thanked: 1 time
Been thanked: 3 times

my gta v6 turbo

Postby andy001 » Mon Mar 26, 2012 10:03 pm

Image

this is my turbo that i have owned since 1998, its been off the road for the last 18 months and as the weather is getting better and i need something to go to prescot in i've had a look at the car and decided its time i spent some money and time on the car.
at the end of 2010 it started to be difficult to start in the morning and then it snowed and it ended up covered in six inches of the stuff and the car would then not start at all, it was later pushed in to the garage and has been there ever since.
i put a battery on it today, took all the plugs out and cranked the engine over and got some oil presure to show on the gauge. cleaned the plugs, refit them and turned the engine over several times, it spluttered a few times but would'nt start.
i've ordered new plugs, distributor cap and rotor arm, so once these are fitted hopefully it should run again.
User avatar
User

PaulC1959

Rank

Club Member

Club Member
Posts

1102

Joined

Sun Oct 15, 2006 8:56 pm

Location

Bedfordshire


Has thanked: 1 time
Been thanked: 5 times

Postby PaulC1959 » Mon Mar 26, 2012 11:02 pm

It sure looks pretty though. :wink:
Venturi 260 - Saphir (Bleu)
Renault Sport Megane 230 F1 Team R26 - Liquid Yellow
Renault Megane Maxim 1.5 DCi - Extreme Blue (Daily Runner)
Minari RS - Coral Red
Smart Roadster Coupe 80 - Spice Red
User avatar
User

PaulyA610

Rank

Club Member

Club Member
Posts

896

Joined

Sat Nov 14, 2009 9:30 pm

Location

Gloucester


Has thanked: 1 time
Been thanked: 3 times

Postby PaulyA610 » Mon Mar 26, 2012 11:28 pm

This is a minter that is for sure!!! It will be nice to see it again at Prescott!!
Venturi Atlantique 300
Renault R8
Renault Kangoo 182
Renault megane R.S 250 Cup

GAZ Suspension Dealer,SPAX Dealer, Forge Motorsport Dealer,Alpine ICE Dealer,
no avatar
User

andy001

Rank

Non Member

Posts

974

Joined

Sat Jul 18, 2009 6:09 pm


Has thanked: 1 time
Been thanked: 3 times

Postby andy001 » Wed Mar 28, 2012 9:05 pm

fitted a new dizzy cap and rotor arm last night and it certainly needed it

Image

the car still won't start and there's no spark from the coil lead, going to do some checks tomorrow.
User avatar
User

jonc

Rank

Club Member

Club Member
Posts

374

Joined

Mon Jul 16, 2007 11:08 am

Location

Oxfordshire


Has thanked: 21 times
Been thanked: 5 times

Postby jonc » Tue Apr 03, 2012 11:06 am

If you're not getting any spark, have a quick test of the TDC sensor to make sure it's not open circuit. Easy to test as the connector is right at the top near the main loom (clipped to the injector rail on the RHS, IIRC).

Probably not this, but as it's so easy to get to and test, got worth checking.
no avatar
User

andy001

Rank

Non Member

Posts

974

Joined

Sat Jul 18, 2009 6:09 pm


Has thanked: 1 time
Been thanked: 3 times

Postby andy001 » Tue Apr 03, 2012 10:55 pm

thanks for that jon, it probably is the tdc censor i've just been a bit busy and not got back to the car yet and now its snowing outside :twisted: :twisted: :twisted:
no avatar
User

andy001

Rank

Non Member

Posts

974

Joined

Sat Jul 18, 2009 6:09 pm


Has thanked: 1 time
Been thanked: 3 times

Postby andy001 » Wed Jan 30, 2013 10:16 am

found the photos i took of my car back in 1998 when i bought it. at the time it was 9 years old, and there was another for sale in london for £13,500 i went all the way down to dover and offered this guy £5000 it was trashed.

Image

no speakers, all the carpets were ripped and dirty, it had all the usual problems,broken headlamp covers, speedo fault, poor clutch, engine would cut out when you went over a bump, but i've never seen a gta with such faded paint. the only gloss on the car was the rear spoiler panel because it had painted the rest was all original. the top surfaces had all gone milky and the lacquer was dead and would'nt polish back up.

Image

Image

you know me lets get the imortant bit done first :lol: respray and colour change.

Image

got the car back home after a few months and fixed all the faults.

Image

i must get a tdc sensor and get it back on the road this year.
User avatar
User

phildini

Rank

Club Member

Club Member
Posts

1762

Joined

Sun Apr 18, 2004 10:00 am

Location

Epsom Surrey/ Venezia Italy


Has thanked: 7 times
Been thanked: 0 time

Postby phildini » Wed Jan 30, 2013 8:45 pm

andy001 wrote:.......i must get a tdc sensor and get it back on the road this year.


Might be a double dip recession out there, but it seem to be quite a few cars getting back on the road this year. :D :D
84 R5 Le Car2 Turbo, 95 Clio 16V mk1, 68 Alfa Romeo 1750 GTV, 99 Mitsubishi Evo VI, 06 Porsche Boxster, 11 Lotus Evora S
no avatar
User

Bob C

Rank

Non Member

Posts

32

Joined

Wed Apr 04, 2007 10:05 pm

Location

Brittany France


Has thanked: 0 time
Been thanked: 0 time

my gta V6 turbo

Postby Bob C » Thu Jan 31, 2013 12:06 am

Mine as well this year, its been sat in the garage for five years and i have taken too much stick from family and friends :twisted:

Looks nice Andy and a nice colour


  • Advertisement

Who is online

Users browsing this forum: No registered users and 14 guests

Powered by phpBB ® | Renault' and 'Alpine' are trademarks of Renault S.A.S. or its subsidiaries and are used with kind permission of Renault France
cron